
Вопрос задан 29.11.2018 в 21:53.
Предмет Информатика.
Спрашивает Невмержицкая Кристина.
Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа
либо произведение нечетного четырехзначного числа

Ответы на вопрос

Отвечает Конев Дмитрий.
Программа:
program abc;
var x,s,p:integer;
begin
writeln('Введите четырехзначное число');
readln(x);
if (x mod 2)=0 then
begin
s:=(x mod 10)+(x div 10 mod 10)+(x div 100 mod 10)+x div 1000;
writeln('s=',s);
end
else
begin
p:=(x mod 10)*(x div 10 mod 10)*(x div 100 mod 10)*x div 1000;
writeln('p=',p);
end;
end.
Блок-схема
program abc;
var x,s,p:integer;
begin
writeln('Введите четырехзначное число');
readln(x);
if (x mod 2)=0 then
begin
s:=(x mod 10)+(x div 10 mod 10)+(x div 100 mod 10)+x div 1000;
writeln('s=',s);
end
else
begin
p:=(x mod 10)*(x div 10 mod 10)*(x div 100 mod 10)*x div 1000;
writeln('p=',p);
end;
end.
Блок-схема



Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili