
Вопрос задан 29.11.2018 в 01:54.
Предмет Информатика.
Спрашивает Бурцева Даша.
составить программу в ПаскалеМассив A(M,N) заполнить случайными числами из промежутка [-15;-8] и
подсчитать произведение элементов чётных строк.Исходный массив и результат вывести на экран

Ответы на вопрос

Отвечает Захаров Егор.
Вместо 20 можно подставить любое число, 20 соответствует M,N
program new;
var a:array [1..20,1..20] of integer; i,j,sum:integer;
begin
randomize;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
a[i,j]:=random(8)-15
end;
end;
for i=2 to 20 do
begin
for j=1 to 20 do
begin
sum:=sum+a[i,j];
i:=i+2;
end;
end;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
write(a[i,j]);
end;
writeln;
end;
writeln('Сумма равна ',sum:8);
end.
P.S.
Делал без паскаля если какие то ошибки то пиши
program new;
var a:array [1..20,1..20] of integer; i,j,sum:integer;
begin
randomize;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
a[i,j]:=random(8)-15
end;
end;
for i=2 to 20 do
begin
for j=1 to 20 do
begin
sum:=sum+a[i,j];
i:=i+2;
end;
end;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
write(a[i,j]);
end;
writeln;
end;
writeln('Сумма равна ',sum:8);
end.
P.S.
Делал без паскаля если какие то ошибки то пиши


Топ вопросов за вчера в категории Информатика

Информатика 566

Информатика 25

Информатика 22

Информатика 27

Информатика 34

Информатика 58

Информатика 63

Информатика 23
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili