Вопрос задан 23.11.2018 в 18:15. Предмет Информатика. Спрашивает Рубцов Сергей.

Написать программу. Ввести последовательность чисел размерностью n. В этой последовательности:

найти минимальный и максимальный элементы. среднее арифметическое отрицательных чисел Вывести на экран значения min и max элементов и их номера, и среднее арифметическое
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ковалевский Даниил.
// PascalABC.NET 3.0, сборка 1088
var
  n,i,max,min,s,t,k:integer;
begin
  Write('Введите количество членов последовательности: ');
  Read(n);
  Writeln('Вводите числа через пробел');
  max:=-32768; min:=32767; s:=0; k:=0;
  for i:=1 to n do begin
    Read(t);
    if t<min then min:=t
    else
      if t>max then max:=t;
    if t<0 then begin s:=s+t; Inc(k) end
    end;
  Writeln('Min=',min,', max=',max,', ср.арифм.=',s/k:0:5)
end.

Тестовое решение:
Введите количество членов последовательности: 7
Вводите числа через пробел
25 -6 39 -118 271 24 -15
Min=-118, max=271, ср.арифм.=-46.33333
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос