Вопрос задан 22.11.2018 в 14:56.
Предмет Информатика.
Спрашивает Barbq-Junior Андрюха.
Язык Pascal ABC. Напишите программу: Дан двухмерный массив A[1..m,1..n]. Написать программу
построения одномерного массива B[1..m], элементы которого соответственно равны суммам элементов строк.Ответы на вопрос
Отвечает Фролова Алина.
Const
m=100;
n=100;
var
a:array[1..m,1..n]of integer;
b:array[1..m]of integer;
i,j:integer;
begin
for i:=1 to m do
for j:=1 to n do
a[i,j]:=random(200)-100;
for i:=1 to m do
b[i]:=0;
for i:=1 to m do
for j:=1 to n do
b[i]:=b[i]+a[i,j];
for i:=1 to m do
write(b[i],' ');
end.
m=100;
n=100;
var
a:array[1..m,1..n]of integer;
b:array[1..m]of integer;
i,j:integer;
begin
for i:=1 to m do
for j:=1 to n do
a[i,j]:=random(200)-100;
for i:=1 to m do
b[i]:=0;
for i:=1 to m do
for j:=1 to n do
b[i]:=b[i]+a[i,j];
for i:=1 to m do
write(b[i],' ');
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
