Вопрос задан 08.11.2018 в 11:59. Предмет Информатика. Спрашивает Усманов Даниял.

Составить программу, позволяющую определить, имеет ли число, введённое с клавиатуры целый корень(

через оператор if)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нефёдов Максим.
Program s;
 var i : integer;
begin
 readln(i)
 if frac(sqrt(i)) = 0 then write('Yes.')
 else write ('No.');
end.
0 0
Отвечает Майская Евгения.
Var a:real;
begin readln(a);
 if frac(sqrt(a))=0 then write('Да')
                    else write('Нет');
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа, позволяющая определить, имеет ли число, введенное с клавиатуры, целый корень, может быть составлена следующим образом:

1. Пользователю будет предложено ввести число с клавиатуры. 2. Число будет сохранено в переменной. 3. С помощью оператора if будет проверено, имеет ли число целый корень. Для этого можно использовать функцию math.sqrt(), которая извлекает квадратный корень из числа. 4. Если квадратный корень числа является целым числом, программа выведет сообщение "Число имеет целый корень", иначе программа выведет сообщение "Число не имеет целого корня".

Пример программы на языке Python:

```python import math

# Ввод числа с клавиатуры num = float(input("Введите число: "))

# Проверка наличия целого корня if math.sqrt(num) % 1 == 0: print("Число имеет целый корень") else: print("Число не имеет целого корня") ```

В этом примере программа сначала импортирует модуль math, который содержит функцию sqrt() для вычисления квадратного корня. Затем пользователю предлагается ввести число, которое сохраняется в переменной num. С помощью оператора if проверяется, является ли квадратный корень числа целым числом. Если да, выводится сообщение "Число имеет целый корень", в противном случае выводится сообщение "Число не имеет целого корня".

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос