Вопрос задан 31.10.2018 в 15:58.
Предмет Информатика.
Спрашивает Барабанова Дарья.
Полный ответ пожалуйста!!! Составьте программу,вычисляющую значение функции y=a^{2} +3a+1 , при
вводимом значении a . (ПАСКАЛЬ)Ответы на вопрос
Отвечает Ратцева Анастасия.
Var a,y:integer;
begin
writeln('Введите число a');
read(a);
y:=sqr(a)+3*a+1;
writeln('Значение y = ',y);
end.
begin
writeln('Введите число a');
read(a);
y:=sqr(a)+3*a+1;
writeln('Значение y = ',y);
end.
Отвечает Лагунин Данил.
Var i,j:integer;
begin
readln(i);
j=(i*i)+(i*3)+1;
writeln(j);
end.
begin
readln(i);
j=(i*i)+(i*3)+1;
writeln(j);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, давайте напишем программу на языке Pascal, которая будет вычислять значение функции \(y = a^2 + 3a + 1\) при вводимом значении \(a\). В Pascal программа может выглядеть следующим образом:
```pascal program CalculateFunction;
var a, y: real;
begin // Вводим значение переменной a write('Введите значение a: '); readln(a);
// Вычисляем значение функции y := a * a + 3 * a + 1;
// Выводим результат writeln('Значение функции при a = ', a, ' равно ', y);
// Ждем нажатия клавиши перед завершением программы readln; end. ```
Эта программа просит пользователя ввести значение переменной \(a\), затем вычисляет значение функции \(y\) согласно вашей формуле и выводит результат на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
