Написать программу в Паскале Найти общую сумму выплаченой зарплаты ,если сотрудник работал x часов
,y дней ,получал в час n грн Всего работало m сотрудниковОтветы на вопрос
var sum, x,y,n,m: real;
begin
readln(x,y,n,m);
x:=x+y*24;
sum:=m*x/n;
writeln(sum);
end.
Для решения этой задачи можно написать программу на языке Паскаль. Программа должна запрашивать у пользователя значения переменных x, y, n, m - количество отработанных часов, количество дней, заработную плату в час и общее количество сотрудников соответственно.
Пример программы в Паскале: ```pascal program calculateSalary;
var x, y, n, m: integer; totalSalary: integer;
begin write('Введите количество отработанных часов: '); readln(x); write('Введите количество дней: '); readln(y); write('Введите заработную плату в час: '); readln(n); write('Введите общее количество сотрудников: '); readln(m);
totalSalary := x * y * n * m; // расчет общей суммы выплаченной зарплаты writeln('Общая сумма выплаченной зарплаты: ', totalSalary, ' грн'); end. ```
В данной программе сначала запрашиваются значения переменных x, y, n и m с помощью функции `readln`. Затем осуществляется расчет общей суммы выплаченной зарплаты с помощью операции умножения `*`. Результат выводится на экран с помощью функции `writeln`.
После запуска программы вам будет предложено последовательно ввести значения переменных x, y, n и m. После того, как вы введете все значения, программа сама посчитает и выведет общую сумму выплаченной зарплаты.
Обратите внимание, что в данном примере предполагается, что значения переменных x, y, n и m будут целочисленными. Если вам необходимо работать с дробными числами, необходимо изменить тип переменных на `real` вместо `integer`.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
