Turbo Pascalв прямоугольном треугольнике известны 2 катета, их значения вводятся с
клавиатуры.Вычеслить и вывести на экран sin, cos, tg, ctg.Пожалуйста, помогите составить программу.Ответы на вопрос
begin
readln(a, b);
c := sqrt(sqr(a) + sqr(b));
writeln('sin a = ', b / c);
writeln('cos a = ', a / c);
writeln('tg a = ', b / a);
writeln('ctg a = ', a / b);
writeln();
writeln('sin b = ', a / c);
writeln('cos b = ', b / c);
writeln('tg b = ', a / b);
writeln('ctg b = ', b / a);
end.
Вот так)) Удачи тебе)
Конечно, я могу помочь вам написать программу на Turbo Pascal для вычисления и вывода на экран значений sin, cos, tg и ctg для прямоугольного треугольника.
Вот пример программы:
```pascal program TrigonometryCalculations;
var cathetus1, cathetus2: real; hypotenuse: real; sinValue, cosValue, tanValue, cotanValue: real;
begin // Ввод значений катетов с клавиатуры write('Введите значение первого катета: '); readln(cathetus1); write('Введите значение второго катета: '); readln(cathetus2);
// Вычисление гипотенузы hypotenuse := sqrt(cathetus1 * cathetus1 + cathetus2 * cathetus2);
// Вычисление sin, cos, tg, ctg sinValue := cathetus1 / hypotenuse; cosValue := cathetus2 / hypotenuse; tanValue := cathetus1 / cathetus2; cotanValue := cathetus2 / cathetus1;
// Вывод результатов на экран writeln('Гипотенуза: ', hypotenuse); writeln('sin: ', sinValue); writeln('cos: ', cosValue); // Проверка на ноль перед выводом tg и ctg if cathetus2 <> 0 then writeln('tg: ', tanValue) else writeln('tg не определено (деление на 0)'); if cathetus1 <> 0 then writeln('ctg: ', cotanValue) else writeln('ctg не определено (деление на 0)'); readln; // Ждем, пока пользователь нажмет Enter end. ```
Эта программа сначала запрашивает значения двух катетов с клавиатуры, затем вычисляет гипотенузу и значения sin, cos, tg и ctg. Результаты выводятся на экран. Программа также включает проверку на деление на ноль при вычислении tg и ctg, чтобы избежать ошибок.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
