Нужно написать программу на паскаль Срочно! Нужно сделать треугольник вот такой ---1--- --121--
-12321- 1234231 и тдОтветы на вопрос
var i,j:integer;
begin
for i:=1 to n do
begin
for j:=1 to n-i do write('-');
for j:=1 to i do write(j);
for j:=i-1 downto 1 do write(j);
for j:=1 to n-i do write('-');
writeln;
end;
end.
Результат:
---1---
--121--
-12321-
1234321
Конечно, я могу помочь вам написать программу на паскале для создания такого треугольника. Вот пример кода:
```pascal program Triangle; var i, j, n: integer; begin write('Введите количество строк для треугольника: '); readln(n); for i := 1 to n do begin for j := 1 to n - i do write(' '); for j := 1 to (2 * i) - 1 do write(j mod 10); writeln; end; readln; end. ```
В этой программе мы сначала запрашиваем у пользователя количество строк для треугольника. Затем вложенными циклами проходим по каждой строке и столбцу, чтобы распечатать необходимые значения. Внутренний цикл отвечает за печать чисел, причем используется оператор модуля (`mod`), чтобы числа повторялись. Внешний цикл отвечает за печать пробелов перед каждой строкой.
Вы можете запустить эту программу в среде разработки Pascal, введя необходимое количество строк для треугольника. Таким образом, программа выведет требуемый треугольник с последовательно увеличивающимися числами.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
