Вопрос задан 10.10.2018 в 21:36. Предмет Информатика. Спрашивает Перушкин Кирилл.

Написать программу на С#, которая будет менять в заданном в программе массиве целых чисел все

элементы, которые равны указанному значению, на противоположное значению по знаку.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Назаренко Дима.
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace zamenaZnakaVmassive
{
class Program
{
static void Main(string[] args)
{
int[] mas = new int[10];
Random r = new Random();
Console.WriteLine("Исходный массив: ");
for (int i = 0; i<mas.Length;i++)
{
mas[i] = r.Next(1, 10);
Console.Write(mas[i] + " ");
}
Console.WriteLine();
Console.WriteLine("Введите значение");
int x = int.Parse(Console.ReadLine());
Console.WriteLine("Измененный массив: ");
for (int i =0; i < mas.Length; i++)
{
if (mas[i] == x) mas[i] = mas[i] * (-1);
Console.Write(mas[i] + " ");
}
Console.ReadKey();
{
}
}
}
}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на C#, которая меняет все элементы массива целых чисел, равные указанному значению, на противоположное значение по знаку:

```csharp using System;

class Program { static void Main(string[] args) { // Заданный массив целых чисел int[] numbers = { 1, -2, 3, -4, 5, -6, 7, -8, 9 };

// Указанное значение int value = -4;

// Проходим по всем элементам массива for (int i = 0; i < numbers.Length; i++) { // Если элемент равен указанному значению if (numbers[i] == value) { // Меняем знак элемента на противоположный numbers[i] = -numbers[i]; } }

// Выводим измененный массив Console.WriteLine("Измененный массив:"); foreach (int number in numbers) { Console.WriteLine(number); } } } ```

В данном примере задан массив целых чисел `numbers` и указанное значение `value`. Затем мы проходим по всем элементам массива и, если элемент равен указанному значению, меняем его знак на противоположный, используя операцию умножения на -1. В конце программы выводим измененный массив на экран.

Пример вывода программы:

``` Измененный массив: 1 -2 3 4 5 -6 7 -8 9 ```

В

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос