Вопрос задан 08.10.2018 в 14:13. Предмет Информатика. Спрашивает Бадалов Азат.

Найти сумму элементов массива B[10] Напишите программу на паскале!!!плиз....

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дюкина Элина.
Program summa;
uses crt;
const N =10;
var B:array[1..N] of integer;
        s,i : integer;
begin
s:=0;
for i:=1 to N do
begin
  write( 'B[ ' ,i, ']= ' );  readln(B[i]);
s:=s+B[i];
end;
writeln( 's=' ,s);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal, которая находит сумму элементов массива B[10]:

```pascal program SumArray;

var B: array[1..10] of Integer; // объявляем массив B из 10 элементов типа Integer i, sum: Integer;

begin // Вводим элементы массива B writeln('Введите элементы массива B[10]:'); for i := 1 to 10 do begin write('B[', i, ']: '); readln(B[i]); end;

// Вычисляем сумму элементов массива B sum := 0; for i := 1 to 10 do begin sum := sum + B[i]; end;

// Выводим результат writeln('Сумма элементов массива B[10]: ', sum);

readln; end. ```

Программа начинается с объявления массива `B` из 10 элементов типа `Integer`. Затем она запрашивает у пользователя ввод значений для каждого элемента массива. После ввода программа вычисляет сумму элементов массива и выводит результат.

Вы можете скомпилировать и выполнить эту программу в среде разработки Pascal, такой как Free Pascal или Turbo Pascal.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос