Вопрос задан 03.10.2018 в 02:11. Предмет Информатика. Спрашивает Борзенко Анастасия.

Составить программу в Pascal, которая из слов "финал","урок","турист","балет","окно","линия"

составляет и выводит слово "футбол". Помогите пожалуйста:3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Доронин Артём.
// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
  var a:=Arr('финал','урок','турист','балет','окно','линия');
  a.Select(c->c[1]).Println
end.

Результат
футбол
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Pascal, которая выполняет указанную задачу. Вот пример программы:

```pascal program FormWord;

var words: array[1..6] of string = ('финал', 'урок', 'турист', 'балет', 'окно', 'линия'); resultWord: string = '';

procedure FormFootballWord; var i, j: integer; found: boolean; begin resultWord := ''; // Обнуляем строку результата

// Перебираем каждую букву в слове "футбол" for i := 1 to Length('футбол') do begin found := False;

// Перебираем каждое слово из массива for j := 1 to Length(words) do begin // Если текущая буква совпадает с буквой в слове из массива if words[j][i] = 'футбол'[i] then begin found := True; resultWord := resultWord + words[j][i]; Break; // Прерываем цикл, так как буква найдена end; end;

// Если буква не найдена в текущем положении, выводим сообщение и завершаем программу if not found then begin writeln('Не удалось составить слово "футбол"'); Exit; end; end;

// Выводим сформированное слово "футбол" writeln('Сформированное слово: ', resultWord); end;

begin // Вызываем процедуру для формирования слова "футбол" FormFootballWord;

// Ждем нажатия клавиши перед закрытием программы readln; end. ```

Эта программа создает массив из слов и затем проверяет, можно ли из данных слов составить слово "футбол". Если это возможно, программа выводит сформированное слово. Если нет, она выводит сообщение об ошибке.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос