Вопрос задан 28.09.2018 в 18:34. Предмет Информатика. Спрашивает Шварёва Варвара.

Составить программа.Вывода суммы разрядов двухзначных чисел(Pacsal abc) Пример: 12 т.е 1+2=3 16

т.е. 1+6=7
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Kout Paul.
Program xxx;
var
i : integer;
begin
writeln('Введите двухзначное число...');
readln(i);
writeln('Ответ:', (i div 10)+(i mod 10));
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Pascal, которая будет выводить сумму разрядов двузначных чисел. Вот пример:

```pascal program SumOfDigits;

var number, digit1, digit2, sum: integer;

begin // Вводим двузначное число write('Введите двузначное число: '); readln(number);

// Проверяем, что введенное число действительно двузначное if (number < 10) or (number > 99) then begin writeln('Ошибка: введено не двузначное число.'); exit; end;

// Разбиваем число на разряды digit1 := number div 10; digit2 := number mod 10;

// Считаем сумму разрядов sum := digit1 + digit2;

// Выводим результат writeln('Сумма разрядов числа ', number, ' равна ', sum);

end. ```

Эта программа сначала запрашивает у пользователя ввод двузначного числа. Затем она проверяет, что введенное число действительно двузначное. Если нет, программа выводит сообщение об ошибке и завершается. Если введено двузначное число, программа разбивает его на разряды (десятки и единицы) и вычисляет их сумму. Результат выводится на экран.

Пример использования программы: ``` Введите двузначное число: 57 Сумма разрядов числа 57 равна 12 ```

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос