Написать программу в паскале . вводим два числа. компьютер должен вывести квадратное
уравнение,корнями которого являются эти два числа. (использоват теорему виета)Ответы на вопрос
begin
readln(x1,x2);{Вводим два числа}
p:=x1+x2;{Вычисляем значение коэффициента при х}
b:=x1*x2;{Вычисляем значение свободного слагаемого}
if p>0 then{Проверка на знак полученных значений и вывод уравнения, как проще сделать со знаком, увы не знаю}
begin
if b>0 then
writeln('x^2-',p,'x+',b,'=0')
else
writeln('x^2-',p,'x-',abs(b),'=0');
end
else
begin
if b>0 then
writeln('x^2+',abs(p),'x+',b,'=0')
else
writeln('x^2+',abs(p),'x-',abs(b),'=0');
end;
end.
Программа на языке Паскаль, которая принимает два числа и выводит квадратное уравнение с этими числами в качестве корней, используя теорему Виета:
```pascal program QuadraticEquation;
var a, b, c: real; x1, x2: real;
begin // Вводим два числа writeln('Введите два числа:'); readln(x1, x2); // Вычисляем коэффициенты квадратного уравнения a := 1; b := - (x1 + x2); c := x1 * x2; // Выводим квадратное уравнение writeln('Квадратное уравнение:'); writeln(a:0:2, 'x^2 + ', b:0:2, 'x + ', c:0:2, ' = 0'); end. ```
Пользователь будет приглашен ввести два числа. Затем программа вычислит коэффициенты квадратного уравнения, используя теорему Виета. Наконец, программа выведет квадратное уравнение в виде `ax^2 + bx + c = 0`, где `a`, `b` и `c` - это вычисленные коэффициенты, а `x` - переменная.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
