
Составить программу нахождения суммы элементов массива, состоящую из 10 чисел. Язык Pascal


Ответы на вопрос

I,s:integer;
Begin
S:=0;
For i:=1 to 10 do
Read(m[i]);
For i:=1 to 10 do
S:=s+m[i];
Write(s);
End.



Конечно! Вот программа на языке Pascal, которая находит сумму элементов массива из 10 чисел:
```pascal program SumOfArray;
var arr: array[1..10] of Integer; i, sum: Integer;
begin // Ввод элементов массива writeln('Введите 10 чисел:'); for i := 1 to 10 do begin write('Число ', i, ': '); readln(arr[i]); end;
// Нахождение суммы элементов массива sum := 0; for i := 1 to 10 do begin sum := sum + arr[i]; end;
// Вывод суммы writeln('Сумма элементов массива: ', sum);
readln; end. ```
Программа начинается с объявления переменных `arr` - массива из 10 целых чисел, `i` - счетчика для циклов, и `sum` - переменной для хранения суммы элементов массива.
Затем следует цикл для ввода 10 чисел с клавиатуры и сохранения их в массиве `arr`.
После этого идет цикл, который проходит по всем элементам массива и суммирует их, сохраняя результат в переменной `sum`.
Затем программа выводит сумму элементов массива на экран.
Наконец, программа ожидает нажатия клавиши Enter, чтобы завершить свою работу.
Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili