Вопрос задан 20.09.2018 в 22:59. Предмет Информатика. Спрашивает Koksharov-Kim Igor.

ПОМОГИТЕ ПЖ РЕШИТЬ ЗАДАЧУ ПО ИНФЕ НА Python!!! 55 балов. В списке все элементы различны. Поменяйте

местами минимальный и максимальный элемент этого списка. Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу. Примеры входные данные 3 4 5 2 1 выходные данные 3 4 1 2 5
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Абдрахманов Нурасыл.
Lst=input("Введите ряд натуральных чисел: ").split()
for i in range(len(lst)):
    lst[i]=int(lst[i])
mx=max(lst)
mn=min(lst)
imx=lst.index(mx)
imn=lst.index(mn)
lst[imx]=mn
lst[imn]=mx
for i in lst:
    print(i,end=" ")

Тестовое решение:
Python 3.4.2 (v3.4.2:ab2c023a9432, Oct  6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> ================================ RESTART ================================
>>>
Введите ряд натуральных чисел: 3 4 5 2 1
3 4 1 2 5
>>>
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример решения задачи на Python:

```python # Ввод списка чисел numbers = list(map(int, input().split()))

# Находим индексы минимального и максимального элементов min_index = numbers.index(min(numbers)) max_index = numbers.index(max(numbers))

# Меняем местами минимальный и максимальный элементы numbers[min_index], numbers[max_index] = numbers[max_index], numbers[min_index]

# Вывод результата print(*numbers) ```

Пример использования: ``` Входные данные: 3 4 5 2 1

Выходные данные: 3 4 1 2 5 ```

Этот код сначала считывает список чисел, затем находит индексы минимального и максимального элементов и меняет их местами. Наконец, выводится измененный список.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос