Вопрос задан 18.09.2018 в 00:59. Предмет Информатика. Спрашивает Брюхов Роман.

В си ++ составить программу, которая выводит остаток при делении числа a на число b. Можите дать

ссылку на сайт, где есть ответ или сами мне написать. Буду благодарна!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Попович Илья.
Решение во вложении.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам с написанием программы на языке Си, которая будет выводить остаток при делении числа `a` на число `b`. Вот простой пример кода:

```c #include

int main() { int a, b;

// Вводим числа a и b printf("Введите число a: "); scanf("%d", &a);

printf("Введите число b: "); scanf("%d", &b);

// Проверяем, что b не равно нулю (деление на ноль недопустимо) if (b != 0) { // Выводим остаток от деления int remainder = a % b; printf("Остаток от деления %d на %d равен %d\n", a, b, remainder); } else { // Выводим сообщение об ошибке, если b равно нулю printf("Ошибка: деление на ноль недопустимо\n"); }

return 0; } ```

Как использовать этот код:

1. Введите значение для переменной `a`. 2. Введите значение для переменной `b`. Обратите внимание, что в этом коде предусмотрена проверка на ноль для переменной `b`, чтобы избежать деления на ноль.

Этот код выполняет простую операцию ввода двух чисел и вывода остатка при их делении. Если у вас возникнут вопросы или есть что-то еще, что вы хотели бы уточнить, не стесняйтесь спрашивать!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос