
Написать программу, которая определяет какой элемент максимальный или минимальный первым
встречается в одномерном массиве из 10 чисел(паскаль)

Ответы на вопрос

var a,i,max,min,k,p:integer;
m:array [1..n] of integer;
begin
for i:=1 to n do
begin
a:=random(21)-10;
m[i]:=a;
write (m[i],' ');
end;
max:=m[1];
min:=m[1];
k:=1;
p:=1;
for i:=1 to n do
begin
if m[i]>max then
begin
max:=m[i];
p:=i;
end;
if m[i]<min then
begin
min:=m[i];
k:=i;
end;
end;
if p>k then writeln ('минимальный раньше')
else writeln ('максимальный раньше');
end.



--------------------




В Паскале можно написать программу для определения того, какой элемент (максимальный или минимальный) первым встречается в одномерном массиве из 10 чисел. Вот пример кода на Паскале:
```pascal program FindMaxMinElement;
var arr: array [1..10] of Integer; // Объявляем массив из 10 элементов i, maxElement, minElement: Integer;
begin // Заполняем массив случайными числами Randomize; for i := 1 to 10 do arr[i] := Random(100); // Генерируем случайные числа от 0 до 99
// Инициализируем переменные maxElement и minElement значением первого элемента массива maxElement := arr[1]; minElement := arr[1];
// Проходим по массиву и находим максимальный и минимальный элементы for i := 2 to 10 do begin if arr[i] > maxElement then maxElement := arr[i] else if arr[i] < minElement then minElement := arr[i]; end;
// Выводим результаты writeln('Максимальный элемент: ', maxElement); writeln('Минимальный элемент: ', minElement); end. ```
Этот код создает массив из 10 случайных чисел и затем находит максимальный и минимальный элементы в массиве. После этого выводит результаты на экран.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili