Вопрос задан 13.09.2018 в 19:05. Предмет Информатика. Спрашивает Иваночко Ваня.

Написать программу нахождения в одномерном массиве С [1..6] произведения и количества элементов

кратных 5 Ребят прошу помочь я тему не понял))) Спасибо за внимание)!Пожалуйста)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рудько Олег.
Uses Crt;

const
  n=6;
var
  i,k:byte;
  p:longint;
  a:array[1..n] of shortint;
begin
  Randomize;
  k:=0; p:=1;
  ClrScr;
  for i:=1 to n do begin
    a[i]:=Random(51)-25;  { [-25..25] }
    Write(a[i],' ');
    if a[i] mod 5=0 then begin k:=k+1; p:=p*a[i] end
    end;
  Writeln; Writeln('k=',k,', P=',p);
  ReadKey
end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на C++ для нахождения произведения элементов и количества элементов, кратных 5, в одномерном массиве. Вот пример кода:

```cpp #include

int main() { // Объявление массива int arr[6];

// Ввод элементов массива с клавиатуры std::cout << "Введите элементы массива (6 штук): "; for (int i = 0; i < 6; ++i) { std::cin >> arr[i]; }

// Инициализация переменных для произведения и количества элементов, кратных 5 int product = 1; int countMultiplesOf5 = 0;

// Вычисление произведения и количества элементов, кратных 5 for (int i = 0; i < 6; ++i) { product *= arr[i];

if (arr[i] % 5 == 0) { countMultiplesOf5++; } }

// Вывод результата std::cout << "Произведение элементов массива: " << product << std::endl; std::cout << "Количество элементов, кратных 5: " << countMultiplesOf5 << std::endl;

return 0; } ```

Программа запрашивает у пользователя ввод шести элементов массива, затем вычисляет произведение всех элементов и подсчитывает количество элементов, кратных 5. В конце программа выводит результаты на экран.

Вы можете скомпилировать и запустить этот код в среде разработки C++ или в командной строке с помощью компилятора, например, g++:

```bash g++ ваш_файл.cpp -o ваш_файл ./ваш_файл ```

Надеюсь, это поможет вам лучше понять тему! Если у вас есть дополнительные вопросы или что-то неясно, не стесняйтесь спрашивать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос