Дан массив А(15). Его элементы задаются случайным образом от -35 до 50. Найти сумму и среднее
значение отрицательных эл-тов, сумму и кол-во положительных эл-тов. Решить всё в паскалеОтветы на вопрос
begin
var a:=ArrRandom(15,-35,50); a.Println;
Writeln('Сумма отр.=',a.Where(x->x<0).Sum,', ср.арифм.отр=',
a.Where(x->x<0).Average:0:5);
Writeln('Сумма пол.=',a.Where(x->x>0).Sum,', кол-во пол.=',
a.Where(x->x<0).Count)
end.
Тестовое решение
13 9 18 -29 -33 7 41 -15 -2 10 7 -32 13 16 -1
Сумма отр.=-112, ср.арифм.отр=-18.66667
Сумма пол.=134, кол-во пол.=6
Для решения данной задачи вам потребуется написать программу на языке Паскаль. Вот пример кода, который может помочь вам решить задачу:
```pascal program ArraySumAverage; const N = 15; var A: array[1..N] of Integer; i, negativeSum, positiveSum, negativeCount, positiveCount: Integer; negativeAverage, positiveAverage: Real; begin // Заполнение массива случайными числами от -35 до 50 Randomize; for i := 1 to N do A[i] := Random(86) - 35;
// Вычисление суммы и среднего значения отрицательных элементов negativeSum := 0; negativeCount := 0; for i := 1 to N do begin if A[i] < 0 then begin negativeSum := negativeSum + A[i]; Inc(negativeCount); end; end; if negativeCount > 0 then negativeAverage := negativeSum / negativeCount else negativeAverage := 0;
// Вычисление суммы и количества положительных элементов positiveSum := 0; positiveCount := 0; for i := 1 to N do begin if A[i] > 0 then begin positiveSum := positiveSum + A[i]; Inc(positiveCount); end; end;
// Вывод результатов Writeln('Сумма отрицательных элементов: ', negativeSum); Writeln('Среднее значение отрицательных элементов: ', negativeAverage:0:2); Writeln('Сумма положительных элементов: ', positiveSum); Writeln('Количество положительных элементов: ', positiveCount); end. ```
Программа создает массив `A` из 15 элементов и заполняет его случайными числами от -35 до 50. Затем она вычисляет сумму и среднее значение отрицательных элементов, а также сумму и количество положительных элементов. Результаты выводятся на экран.
Примечание: В данном случае я использовал язык Паскаль для написания программы, так как вы указали, что хотите решить задачу именно на Паскале. Однако, вы можете использовать любой другой язык программирования, с которым вам удобнее работать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
