СРОЧНО!! Написать программу, которая вводит три числа – А, В, С и распечатывает только те из них,
которые КРАТНЫ 3 и ОКАНЧИВАЮТСЯ на 5. Если таких чисел нет, напечатать слово НЕТ. Например, если введены числа: 15, 25, 45, то распечатаны должны быть числа 15 и 45. Если введены числа 15, 60, 25, то распечатано должно быть только число 15. Если введены числа 14, 25, 60, то должно быть напечатано слово НЕТ.Ответы на вопрос
k:boolean;
begin
readln(a);
readln(b);
readln(c);
k:=false;
if (a mod 3=0) and (a mod 10=5) then
begin;
writeln(a);
k:=true;
end;
if (b mod 3=0) and (b mod 10=5) then
begin;
writeln(b);
k:=true;
end;
if (c mod 3=0) and (c mod 10=5) then
begin;
k:=true;
writeln(c);
end;
if k=false then writeln('НЕТ');
end.
Конечно, вот пример программы на языке Python, которая выполняет указанную задачу:
```python # Вводим три числа A = int(input("Введите число A: ")) B = int(input("Введите число B: ")) C = int(input("Введите число C: "))
# Проверяем условия и выводим результат if A % 3 == 0 and A % 5 == 0: print(A) if B % 3 == 0 and B % 5 == 0: print(B) if C % 3 == 0 and C % 5 == 0: print(C)
# Если не найдено чисел, удовлетворяющих условиям, выводим "НЕТ" if not (A % 3 == 0 and A % 5 == 0) and not (B % 3 == 0 and B % 5 == 0) and not (C % 3 == 0 and C % 5 == 0): print("НЕТ") ```
Программа запрашивает у пользователя три числа, затем проверяет каждое из них на соответствие условиям (кратность 3 и оканчивание на 5) и выводит соответствующие числа или слово "НЕТ", если подходящих чисел нет.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
