Вопрос задан 30.08.2018 в 19:03. Предмет Информатика. Спрашивает Буланцев Эдуард.

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки

двумерного массива целых чисел паскаль абс
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Астапенко Стас.
Const
  m=10;
  n=8;
var
  a:array[1..m,1..n] of integer;
  i,j:integer;
  p:double;

begin
  Randomize;
  Writeln('Исходный массив');
  for i:=1 to m do
  begin
    for j:=1 to n do
    begin
      a[i,j]:=Random(101)-50;
      Write(a[i,j]:4);
    end;
    Writeln
  end;
  p:=1;
  for j:=1 to n do
      if a[3,j]>0 then p:=p*a[3,j];
  Writeln('Искомое произведение: ',p)
end.

Тестовое решение:
Исходный массив
  35  30  35 -25 -50   8 -20  47
 -34 -26  -7  34  -9 -31  10 -46
 -17 -21  27   8  27  41  35 -48
  30 -44  25  48  30 -20  10  -6
  -3 -10  45 -33   3 -38 -11  -8
  47 -25 -27  -7   2 -20  -4 -48
 -38  32 -29 -41  31  16  46  44
  45  33  -4  45  34 -18 -33  37
  15  49 -14 -49 -25  -8   1 -30
  41 -15  11   1  17  -8   0  -1
Искомое произведение: 8368920

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи в Паскале можно использовать следующий код:

```pascal program MultiplyPositiveElements;

const N = 3; // количество строк M = 3; // количество столбцов

type Matrix = array[1..N, 1..M] of integer;

var array2D: Matrix; i, j: integer; product: integer;

begin // Ввод элементов двумерного массива writeln('Введите элементы двумерного массива:'); for i := 1 to N do begin for j := 1 to M do begin write('array2D[', i, '][', j, '] = '); readln(array2D[i, j]); end; end;

// Вычисление произведения положительных элементов третьей строки product := 1; for j := 1 to M do begin if array2D[3, j] > 0 then product := product * array2D[3, j]; end;

// Вывод результата writeln('Произведение положительных элементов третьей строки: ', product);

end. ```

В данном коде объявляется двумерный массив `array2D` размером `N` строк и `M` столбцов. Далее происходит ввод элементов массива с помощью вложенных циклов `for`. Затем идет вычисление произведения положительных элементов третьей строки с помощью цикла `for` и условного оператора `if`. Результат выводится на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос