(Турбо Паскаль 9 класс)Написать программу нахождения стоимости покупки. Число шоколада и мороженого
вводится с клавиатуры. Число стоимости одной шоколадки -1200 , мороженого-3800Ответы на вопрос
program test;
var sum, x: integer;
begin
sum:=0;
write('Enter the amount of chocolate: ');
readln(x);
sum:=sum+1200*x;
write('Enter the amount of ice cream: ');
readln(x);
sum:=sum+3800*x;
writeln('Total cost of purchase = ', sum);
readln;
end.
Программа нахождения стоимости покупки
Для написания программы нахождения стоимости покупки, где число шоколада и мороженого вводится с клавиатуры, а стоимость одной шоколадки равна 1200, а мороженого - 3800, можно использовать следующий код на языке Turbo Pascal:
```pascal program PurchaseCost;
var numChocolates, numIceCreams: integer; costChocolates, costIceCreams, totalCost: integer;
begin writeln('Введите количество шоколада:'); readln(numChocolates); writeln('Введите количество мороженого:'); readln(numIceCreams); costChocolates := numChocolates * 1200; costIceCreams := numIceCreams * 3800; totalCost := costChocolates + costIceCreams; writeln('Общая стоимость покупки:', totalCost); end. ```
В этой программе мы используем переменные `numChocolates` и `numIceCreams` для хранения введенных с клавиатуры значений количества шоколада и мороженого соответственно. Затем мы вычисляем стоимость шоколада и мороженого, умножая их количество на соответствующую стоимость. И, наконец, мы суммируем обе стоимости, чтобы получить общую стоимость покупки. Результат выводится на экран с помощью функции `writeln`.
Пример работы программы:
``` Введите количество шоколада: 2 Введите количество мороженого: 3 Общая стоимость покупки: 16600 ```
Пожалуйста, обратите внимание, что в данном примере мы предполагаем, что пользователь будет вводить только целочисленные значения количества шоколада и мороженого. Если требуется обработка ошибок ввода, то код программы может быть дополнен соответствующими проверками и обработкой исключений.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
