 
Вопрос задан 24.08.2018 в 08:02.
Предмет Информатика.
Спрашивает Гонтовая Полина.
Помогите написать программу на C++ Тема была Булева алгебра. Сначала нужно выяснить что будет в
данном условии( Тру или фолс) и написать программу которая вычислит данное условие. Во вложении. PS В конце там меньше или равно 0
 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Трач Алексей.
                
     (y>x*x) && b && (x*x*y*y>1)&&(y<7)&&(x>0.5)||(y*y<=0) ⇒
(-1>(-2)*(-2)) && true && ((-2)*(-2)*(-1)*(-1)>1)&&((-1)<7)&&((-2)>0.5)||((-1)*(-1)<=0) ⇒
(-1>4) && true && (4>1)&&(-1<7)&&(-2>0.5) || (1<=0) ⇒
false && true && true && true && false || false ⇒
false || false ⇒ false
#include <iostream>
using namespace std;
int main() {
int x = -2, y = -1;
bool b = true, z;
z = (y>x*x) && b && (x*x*y*y>1)&&(y<7)&&(x>0.5)||(y*y<=0);
cout << "z = " << z;
return 0;
}
Результат:
z = 0
                                        (-1>(-2)*(-2)) && true && ((-2)*(-2)*(-1)*(-1)>1)&&((-1)<7)&&((-2)>0.5)||((-1)*(-1)<=0) ⇒
(-1>4) && true && (4>1)&&(-1<7)&&(-2>0.5) || (1<=0) ⇒
false && true && true && true && false || false ⇒
false || false ⇒ false
#include <iostream>
using namespace std;
int main() {
int x = -2, y = -1;
bool b = true, z;
z = (y>x*x) && b && (x*x*y*y>1)&&(y<7)&&(x>0.5)||(y*y<=0);
cout << "z = " << z;
return 0;
}
Результат:
z = 0
 0
                    0
                     0
                    0
                 
        Отвечает Korolenko Aleksandr.
                
     Альтернативная программа, результат тот же, что и у PetyaGavrikov
#include <bits/stdc++.h>
using namespace std;
int main(){
int x = -2;
int y = -1;
bool z = (y > x*x + 1 + x*x*y*y > 1 + y < 7 + x > 0.5 && y*y <= 0 );
cout << z;
}
                                        #include <bits/stdc++.h>
using namespace std;
int main(){
int x = -2;
int y = -1;
bool z = (y > x*x + 1 + x*x*y*y > 1 + y < 7 + x > 0.5 && y*y <= 0 );
cout << z;
}
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			