Вопрос задан 24.08.2018 в 03:38. Предмет Информатика. Спрашивает Гасанов Артем.

Составить программу на определение суммы элементов массива( одномерный двумерный)

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бочаров Тимофей.
Вот программа для массива состоящих,например из 7 чисел

var
a:array[1..7]of integer;
i,n,m:integer;
begin
m:=0;
Writeln('введите числа:'); 
For i:=1 to 7 do 
Readln (a[i]);
for i:=1 to 7 do
m:=a[i]+m;
writeln(m);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для определения суммы элементов в массиве, как одномерном, так и двумерном, можно использовать следующую программу:

Одномерный массив:

```c #include

int main() { int n, i, sum = 0; printf("Введите размер массива: "); scanf("%d", &n); int arr[n]; printf("Введите элементы массива:\n"); for (i = 0; i < n; i++) { printf("arr[%d]: ", i); scanf("%d", &arr[i]); } for (i = 0; i < n; i++) { sum += arr[i]; } printf("Сумма элементов массива: %d\n", sum); return 0; } ```

Двумерный массив:

```c #include #include

void sumOfElements(double **matr, int R, int C) { int i, j; double sum = 0.0; for (i = 0; i < R; i++) { for (j = 0; j < C; j++) { sum += matr[i][j]; } } printf("Сумма элементов массива: %.2lf\n", sum); }

int main() { int R, C, i, j; printf("Введите количество строк: "); scanf("%d", &R); printf("Введите количество столбцов: "); scanf("%d", &C); double matr = (double )malloc(R * sizeof(double *)); for (i = 0; i < R; i++) { matr[i] = (double *)malloc(C * sizeof(double)); } printf("Введите элементы массива:\n"); for (i = 0; i < R; i++) { for (j = 0; j < C; j++) { printf("matr[%d][%d]: ", i, j); scanf("%lf", &matr[i][j]); } } printf("Массив:\n"); for (i = 0; i < R; i++) { for (j = 0; j < C; j++) { printf("%.2lf ", matr[i][j]); } printf("\n"); } sumOfElements(matr, R, C); for (i = 0; i < R; i++) { free(matr[i]); } free(matr); return 0; } ```

После ввода размеров массива и его элементов, программа вычисляет сумму элементов и выводит ее на экран.

Примечание: В коде используется динамическое выделение памяти для двумерного массива. После использования массива, необходимо освободить выделенную память с помощью функции `free()`.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос