Составить программу в Pascal 1)в строке , введенной с клавиатуры , все буквы И заменить на % 2)из
строки, введенной с клавиатуры , удалить все символы ,начиная с середины.Ответы на вопрос
var
s:string;
i:longint;
begin
read(s);
for i:=1 to length(s) do
if s[i]='И' then s[i]:='%';
writeln(s);
end.
2)
var
s:string;
l:longint;
begin
read(s);
l:=length(s);
delete(s, (l div 2)+1, l-(l div 2));
writeln(s);
end.
Программа на Pascal, которая заменяет все буквы "И" на символ "%":
```pascal program ReplaceLetters; uses crt;
var inputString, outputString: string; i: integer;
begin clrscr; writeln('Введите строку:'); readln(inputString);
outputString := '';
for i := 1 to length(inputString) do begin if inputString[i] = 'И' then outputString := outputString + '%' else outputString := outputString + inputString[i]; end;
writeln('Исходная строка: ', inputString); writeln('Строка после замены: ', outputString);
readln; end. ```
Программа на Pascal, которая удаляет все символы, начиная с середины строки:
```pascal program RemoveMiddleCharacters; uses crt;
var inputString, outputString: string; middleIndex, i: integer;
begin clrscr; writeln('Введите строку:'); readln(inputString);
middleIndex := length(inputString) div 2;
outputString := '';
for i := 1 to length(inputString) do begin if i < middleIndex then outputString := outputString + inputString[i]; end;
writeln('Исходная строка: ', inputString); writeln('Строка после удаления символов: ', outputString);
readln; end. ```
Оба этих программы считывают строку с клавиатуры, выполняют необходимые операции и выводят результат на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
