Даны 3 переменные,составить программу:если все они =;выдает сообщение:переменные=,в противном
случае каждую из них увеличь на 10Ответы на вопрос
var a,b,c: real;
begin
readln(a,b,c);
if (a=b) and (a=c) and (c=b)
then writeln('переменные =')
else
begin
a:=a+10;
b:=b+10;
c:=c+10;
end;
end.
Для решения данной задачи, вам потребуется написать программу, которая проверяет значения трех переменных. Если все три переменные равны между собой, программа должна вывести сообщение "переменные равны". В противном случае, каждую из переменных нужно увеличить на 10.
Вот пример программы на языке Python, который решает данную задачу:
```python # Ввод значений переменных var1 = int(input("Введите значение первой переменной: ")) var2 = int(input("Введите значение второй переменной: ")) var3 = int(input("Введите значение третьей переменной: "))
# Проверка условия if var1 == var2 == var3: print("переменные равны") else: var1 += 10 var2 += 10 var3 += 10 print("Значение первой переменной после увеличения на 10:", var1) print("Значение второй переменной после увеличения на 10:", var2) print("Значение третьей переменной после увеличения на 10:", var3) ```
Вы можете запустить эту программу и ввести значения переменных, чтобы увидеть результат.
Примечание: В данном примере использован язык программирования Python, но вы можете использовать любой другой язык программирования, с которым вам удобно работать.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
