
Помогите написать программу на C++ 1. Описать структуру с именем PUPIL, содержащую следующие поля:
• фамилия и инициалы; • в каком классе учиться; • успеваемость (массив из пяти элементов). 2. Написать программу, выполняющую следующие действия: • ввод с клавиатуры данных в массив, состоящий из десяти структур типа PUPIL; записи должны быть упорядочены по возрастанию среднего балла; • вывод на дисплей фамилий и номеров классов для всех учеников, имеющих оценки 4 и 5; • если таких учеников нет, вывести соответствующее сообщение.

Ответы на вопрос





Конечно, я могу помочь вам написать программу на языке C++.
Вот пример кода, который реализует описанную вами структуру PUPIL и выполняет указанные действия:
```cpp
#include
struct PUPIL { std::string name; int grade; int performance[5]; };
bool compareByAverageGrade(const PUPIL& pupil1, const PUPIL& pupil2) {
int sum1 = 0, sum2 = 0;
for (int i = 0; i < 5; i++) {
sum1 += pupil1.performance[i];
sum2 += pupil2.performance[i];
}
double avg1 = static_cast
int main() { const int NUM_PUPILS = 10; PUPIL pupils[NUM_PUPILS];
// Ввод данных с клавиатуры for (int i = 0; i < NUM_PUPILS; i++) { std::cout << "Введите фамилию и инициалы ученика " << i+1 << ": "; std::cin >> pupils[i].name;
std::cout << "Введите класс, в котором учится ученик " << i+1 << ": "; std::cin >> pupils[i].grade;
std::cout << "Введите успеваемость ученика " << i+1 << " (5 оценок): "; for (int j = 0; j < 5; j++) { std::cin >> pupils[i].performance[j]; } }
// Сортировка по возрастанию среднего балла std::sort(pupils, pupils + NUM_PUPILS, compareByAverageGrade);
// Вывод фамилий и номеров классов для учеников с оценками 4 и 5 bool hasGoodStudents = false; for (int i = 0; i < NUM_PUPILS; i++) { bool hasGoodGrades = false; for (int j = 0; j < 5; j++) { if (pupils[i].performance[j] >= 4) { hasGoodGrades = true; break; } } if (hasGoodGrades) { std::cout << "Ученик " << pupils[i].name << ", класс " << pupils[i].grade << std::endl; hasGoodStudents = true; } }
// Вывод сообщения, если нет учеников с оценками 4 и 5 if (!hasGoodStudents) { std::cout << "Нет учеников с оценками 4 и 5." << std::endl; }
return 0; } ```
Надеюсь, это поможет вам написать программу, которая описывает структуру PUPIL и выполняет указанные действия. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili