Вопрос задан 14.08.2018 в 04:01. Предмет Информатика. Спрашивает Ногманова Марьям.

Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит

две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Чижов Вадим.
Var
s:string;
i:longint;
t:boolean;

begin
read(s);
t:=false;

for i:=1 to length(s)-1 do
 if s[i]=s[i+1] then t:=true;

if t then writeln('YES') else writeln('NO');
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль для определения наличия двух одинаковых цифр, стоящих рядом

Для решения данной задачи на языке Паскаль можно использовать следующий код:

```pascal program CheckAdjacentDigits; var number: string; i: integer; hasAdjacentDigits: boolean; begin hasAdjacentDigits := false; // Ввод числа write('Введите число: '); readln(number); // Проверка наличия двух одинаковых цифр, стоящих рядом for i := 1 to length(number) - 1 do begin if number[i] = number[i+1] then begin hasAdjacentDigits := true; break; end; end; // Вывод результата if hasAdjacentDigits then writeln('YES') else writeln('NO'); end. ```

Программа запрашивает у пользователя ввод числа и затем проверяет, есть ли в этом числе две одинаковые цифры, стоящие рядом. Если такая пара цифр найдена, программа выводит 'YES', иначе - 'NO'.

Пример работы программы:

``` Введите число: 221 YES ```

``` Введите число: 12345 NO ```

Примечание: Данный код является примером решения задачи и может быть доработан или оптимизирован в зависимости от требований и особенностей конкретной среды разработки или задачи.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос