
Составить программу вычисления n! (n факториал) F=n!=1*2*3*4*...n 8 класс Паскаль абс


Ответы на вопрос

begin
write('Введите число ');
readln(a);
b:=1;
c:=1;
while c<=a do
begin
b:=b*c;
c:=c+1
end;
write('Факториал числа ',a,' равен ',b)
end.



Для вычисления факториала числа n в программе на языке Паскаль можно использовать цикл и переменную для хранения результата. Вот пример программы:
```pascal program Factorial; var n, i: integer; F: longint; begin write('Введите число n: '); readln(n);
F := 1; for i := 1 to n do F := F * i;
writeln('Факториал числа ', n, ' равен ', F); end. ```
В этой программе мы сначала запрашиваем у пользователя число n. Затем мы инициализируем переменную F значением 1. Затем мы используем цикл for для умножения переменной F на числа от 1 до n. В результате получаем факториал числа n, который выводим на экран.
Например, если пользователь вводит число 5, программа выведет "Факториал числа 5 равен 120".
Примечание: Приведенный выше код является примером программы на языке Паскаль и может быть скомпилирован и запущен в среде разработки, поддерживающей язык Паскаль.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili