Помогите с информатикой! Нужно написать программу в Паскаль ABC "Линейные алгоритмы. Решение задач"
1.Мальчик может бегать в 3 раза быстрее, чем ходить. Скорость его ходьбы составляет А км/час. Мальчик принял участие в марафонском забеге, но сошел с дистанции, пробежав Х км. Сколько времени он затратил? 2. Цех по ремонту бытовой техники имеет ежедневно прибыль Р, с которой платит налог 70%. Из оставшейся доли прибыли 30% идет на развитие производства, а остальное - на заработную плату 8 работникам. Какова заработная плата работника за месяц?Ответы на вопрос
var speed, A, X:integer;
time:real;
begin
readln(A);
readln(X);
speed:= A * 3;
time:= X / speed;
writeln(time);
end.
2)
program znanija3;
var P:integer;
tax, rest, wages, answer:real;
begin
read(P);
tax:=(P*70)/100;
rest:= P - tax;
wages:= (rest*70)/100;
answer:= wages / 8;
writeln(answer);
end.
Решение задачи 1: Мальчик на марафонском забеге
Для решения данной задачи, нам необходимо учесть, что мальчик может бегать в 3 раза быстрее, чем ходить. Скорость его ходьбы составляет А км/час, а он сошел с дистанции, пробежав Х км. Нам нужно найти время, которое он затратил.
Для решения задачи, мы можем использовать следующий алгоритм:
1. Найдем скорость бега мальчика. Она будет равна 3 * А км/час
1. Для решения данной задачи нужно вычислить скорость бега мальчика и затем использовать формулу для вычисления времени.
Дано: Скорость ходьбы мальчика - А км/час Пройденное расстояние - Х км
Сначала найдем скорость бега мальчика. По условию, он бегает в 3 раза быстрее, чем ходит. То есть, скорость бега равна 3А км/час.
Теперь используем формулу для вычисления времени: Время = Расстояние / Скорость
В данном случае, расстояние - Х км, а скорость - 3А км/час.
Таким образом, время, которое мальчик затратил на пробежку, равно: Время = Х / (3А)
2. Для решения данной задачи нужно вычислить общую прибыль цеха по ремонту бытовой техники, а затем использовать формулу для вычисления заработной платы работника.
Дано: Ежедневная прибыль цеха - Р Налог - 70% Доля прибыли, идущая на развитие производства - 30% Количество работников - 8
Сначала найдем общую прибыль цеха за месяц. Для этого умножим ежедневную прибыль на количество рабочих дней в месяце: Общая прибыль = Р * Количество рабочих дней в месяце
Затем найдем сумму налога, который уплачивает цех: Налог = Общая прибыль * (70 / 100)
Теперь найдем долю прибыли, идущую на развитие производства: Доля на развитие производства = Общая прибыль * (30 / 100)
Оставшуюся долю прибыли будем использовать для выплаты заработной платы работникам. Для этого найдем сумму оставшейся доли прибыли и разделим ее на количество работников: Заработная плата работника = (Оставшаяся доля прибыли / Количество работников)
Таким образом, заработная плата работника за месяц будет равна вычисленной сумме.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
