Вопрос задан 08.08.2018 в 06:49. Предмет Информатика. Спрашивает Купяк Маша.

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение

меньшей из его первой и последней цифр. Исходное число не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры. Примеры работы программы: Ввод: 3; Вывод:3 Ввод: 2194; Вывод: 2
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Беркут Илья.
Var a,af,al:integer;
begin
  writeln('Введите число');
  readln(a);
  if a<10 then writeln('Ответ: ',a)
  else
  if a<=99 then
  begin
  af:=a div 10;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=999 then
  begin
  af:=a div 100;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=9999 then
  begin
  af:=a div 1000;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=30000 then
  begin
  af:=a div 10000;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end;
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Ответ: Чтобы написать программу, которая считывает целое положительное число и печатает значение меньшей из его первой и последней цифр, можно использовать следующий алгоритм:

- Считать число с клавиатуры и преобразовать его в строку - Извлечь первую и последнюю цифры из строки, используя индексы - Преобразовать первую и последнюю цифры обратно в числа - Сравнить их и вывести меньшее из них на экран

Пример кода на Python, реализующего этот алгоритм, выглядит так:

```python # Считать число с клавиатуры и преобразовать его в строку num = input("Введите целое положительное число: ") # Извлечь первую и последнюю цифры из строки, используя индексы first_digit = num[0] last_digit = num[-1] # Преобразовать первую и последнюю цифры обратно в числа first_digit = int(first_digit) last_digit = int(last_digit) # Сравнить их и вывести меньшее из них на экран if first_digit < last_digit: print("Меньшая цифра:", first_digit) elif first_digit > last_digit: print("Меньшая цифра:", last_digit) else: print("Первая и последняя цифры равны:", first_digit) ```

Вы можете найти больше информации о работе со строками и числами в Python на этих сайтах: [Работа со строками в Python](https://realpython.com/python-min-and-max/) [Преобразование типов данных в Python](https://www.geeksforgeeks.org/python-program-to-find-smallest-number-in-a-list/) [Индексация и срезы в Python](https://stackoverflow.com/questions/27009247/find-min-max-and-average-of-a-list)

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос