Вопрос задан 07.08.2018 в 23:22. Предмет Информатика. Спрашивает Гурьянов Аверьян.

Pascal.Помогите решать хотя бы некоторые!!!Очень нужно. Задача 1. Ввести три вещественных числа:

длины сторон треугольника. а) Напечатать существует ли треугольник с такими длинами сторон; б) Если треугольник существует, то напечатать тип треугольника: остроугольный, прямоугольный или тупоугольный. Задача 2. Компьютер в первую секунду печатает на экране 1, во вторую – число 12, в третью – число 23. То есть, в каждую следующую секунду – на 11 больше, чем в предыдущую. В какую секунду впервые появится число, делящееся на 2009? Задача 3. Текст состоит из слов, разделенных пробелом. Найти самое длинное слово. Если таких слов несколько, то напечатать последнее. Задача 4. Ввести натуральное число N. Это число записывается в виде суммы нескольких неубывающих натуральных слагаемых. Например, 5=1+4=2+3=1+1+3=1+1+1+2=1+1+1+1+1 Напечатать количество таких изложений (при n=5, ответ 5);
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Назаров Олег.
Вторая задача:
Ловите решение. Программа с помощью цикла увеличивает секунды и само число, каждый раз проверяя, делится ли число на 2009 без остатка. 
Ответ: на 1462 секунду.
Код:
var a, sec, c: integer;
begin  
sec := 1; a := 1; 
while true do begin
 inc(sec, 1);
 a := a + 11; 
writeln('Секунда - ', sec, ' число - ', a); 
if (a mod 2009 = 0) then break;
end;
writeln('Ответ: ', a);   
end.

Третью решу и скину либо сюда, либо в личку.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь с этими задачами на языке программирования Pascal. Давайте начнем с первой задачи.

Задача 1: Проверка существования и определение типа треугольника

Для начала введем три вещественных числа, которые будут представлять длины сторон треугольника. Затем мы можем проверить, существует ли треугольник с такими длинами сторон, а затем определить его тип (остроугольный, прямоугольный или тупоугольный).

```pascal program TriangleType;

var a, b, c: real;

begin writeln('Введите длины сторон треугольника:'); readln(a, b, c);

if (a + b > c) and (a + c > b) and (b + c > a) then begin writeln('Треугольник существует.'); if (a * a + b * b = c * c) or (a * a + c * c = b * b) or (b * b + c * c = a * a) then writeln('Треугольник прямоугольный.') else if (a * a + b * b > c * c) and (a * a + c * c > b * b) and (b * b + c * c > a * a) then writeln('Треугольник остроугольный.') else writeln('Треугольник тупоугольный.'); end else writeln('Треугольник не существует.'); end. ```

Задача 2: Поиск числа, делящегося на 2009

Для решения этой задачи нам нужно написать программу, которая будет увеличивать число на 11 каждую секунду и проверять, делится ли оно на 2009.

```pascal program NumberDivisibleBy2009;

var number, second: integer;

begin number := 1; second := 1;

while number mod 2009 <> 0 do begin number := number + 11; second := second + 1; end;

writeln('Число, делящееся на 2009, появится в ', second, ' секунду.'); end. ```

Задача 3: Поиск самого длинного слова

Для решения этой задачи можно разбить текст на отдельные слова и найти самое длинное из них.

```pascal program LongestWord;

var text, word, longestWord: string; i: integer;

begin writeln('Введите текст:'); readln(text);

text := text + ' '; // добавляем пробел в конце, чтобы обработать последнее слово

word := ''; longestWord := ''; for i := 1 to length(text) do begin if text[i] <> ' ' then word := word + text[i] else begin if length(word) >= length(longestWord) then longestWord := word; word := ''; end; end;

writeln('Самое длинное слово: ', longestWord); end. ```

Задача 4: Количество изложений числа N

Для решения этой задачи можно использовать рекурсивную функцию.

```pascal program NumberSum;

function CountPartitions(n, max: integer): integer; begin if (n = 0) or (max = 1) then CountPartitions := 1 else if max > n then CountPartitions := CountPartitions(n, n) else CountPartitions := CountPartitions(n, max - 1) + CountPartitions(n - max, max); end;

var N: integer;

begin writeln('Введите натуральное число N:'); readln(N);

writeln('Количество изложений числа ', N, ': ', CountPartitions(N, N)); end. ```

Надеюсь, что

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос