 
Паскаль. Составьте программу вычисления площади треугольника с основанием a и высотой h. Значения a
и h введите с клавиатуры. 0
        0
         0
        0
    Ответы на вопрос
 
        var a : integer;
var h : integer;
var res : real;
Readln(a);
Readln(h);
res := a * h / 2;
writeln(res);
end.
 0
                    0
                     0
                    0
                 
            Вычисление площади треугольника в Паскале
Для вычисления площади треугольника с основанием `a` и высотой `h` в Паскале, можно использовать следующую программу:
```pascal program CalculateTriangleArea; var a, h, area: real; begin writeln('Введите значение основания треугольника (a): '); readln(a); writeln('Введите значение высоты треугольника (h): '); readln(h); area := (a * h) / 2; writeln('Площадь треугольника: ', area); end. ```
В этой программе мы объявляем переменные `a`, `h` и `area` типа `real` (вещественное число). Затем мы запрашиваем у пользователя ввод значения основания `a` и высоты `h` с помощью функции `readln`. Далее, мы вычисляем площадь треугольника по формуле `(a * h) / 2` и сохраняем результат в переменную `area`. Наконец, мы выводим результат с помощью функции `writeln`.
Пример работы программы:
``` Введите значение основания треугольника (a): 5
Введите значение высоты треугольника (h): 8
Площадь треугольника: 20 ```
Обратите внимание, что программа ожидает ввода чисел с плавающей точкой (например, 5.0 или 8.5). Если пользователь вводит некорректные значения, программа может выдать ошибку или неправильный результат.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			