Вопрос задан 05.08.2018 в 20:18. Предмет Информатика. Спрашивает Коробкина Дарья.

Написать программу, используя оператор while, для нахождения суммы любых 10 чисел вводимых с

клавиатуры Pascal ABC
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мамаева Полина.
Program n1;
var sum,a: real;
i: integer;
begin
i:=0;
sum:=0;
while i<10 do
begin
readln(a);
sum:=sum+a;
i:=i+1;
end;
write(sum);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа нахождения суммы 10 чисел с использованием оператора while в Pascal ABC

Вот пример программы на языке Pascal ABC, которая позволяет пользователю ввести 10 чисел с клавиатуры и находит их сумму с использованием оператора while:

```pascal program SumOfNumbers; var i, number, sum: integer; begin sum := 0; i := 1; while i <= 10 do begin write('Введите число ', i, ': '); readln(number); sum := sum + number; i := i + 1; end; writeln('Сумма введенных чисел: ', sum); end. ```

В этой программе мы используем переменные `i`, `number` и `sum`. Переменная `i` используется для отслеживания количества введенных чисел и ограничения цикла while. Переменная `number` используется для хранения введенного числа на каждой итерации цикла. Переменная `sum` используется для накопления суммы введенных чисел.

На каждой итерации цикла while программа запрашивает у пользователя ввод числа и добавляет его к переменной `sum`. После ввода 10 чисел программа выводит итоговую сумму.

Примечание: Программа предполагает, что пользователь будет вводить только целые числа. Если вам нужно обрабатывать числа с плавающей запятой, вам следует использовать тип данных `real` вместо `integer`.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос