1) Составить программу вывода на экран первых 10 натуральных чисел 2) Составить программу
вычисления суммы N первых чисел В PascalОтветы на вопрос
begin
summ:=0;
for i:=1 to 10 do begin write(i+' '); summ:=summ+i; end;
writeln;
writeln('сумма первых десяти натуральных чисел =',summ);
end.
Пример работы:
1 2 3 4 5 6 7 8 9 10 сумма первых десяти натуральных чисел =55
Программа вывода на экран первых 10 натуральных чисел
Вот пример программы на языке Pascal, которая выводит на экран первые 10 натуральных чисел:
```pascal program PrintFirstTenNumbers; var i: integer; begin for i := 1 to 10 do writeln(i); end. ```
В этой программе используется цикл `for`, который выполняется 10 раз и выводит значение переменной `i` на каждой итерации. Результатом выполнения программы будет вывод на экран чисел от 1 до 10.
Программа вычисления суммы N первых чисел
Вот пример программы на языке Pascal, которая вычисляет сумму первых N чисел:
```pascal program SumOfFirstNNumbers; var N, sum, i: integer; begin write('Введите значение N: '); readln(N); sum := 0; for i := 1 to N do sum := sum + i; writeln('Сумма первых ', N, ' чисел: ', sum); end. ```
В этой программе пользователю предлагается ввести значение N. Затем с помощью цикла `for` вычисляется сумма первых N чисел и выводится на экран. Например, если пользователь вводит N=5, программа вычислит сумму чисел 1+2+3+4+5 и выведет результат.
Примечание: Обратите внимание, что в приведенных примерах программ используется язык Pascal. Если вы хотите использовать другой язык программирования, пожалуйста, уточните это.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
