Вопрос задан 03.08.2018 в 22:23.
Предмет Информатика.
Спрашивает Амосов Артём.
Составить программу в паскале удалить все пробелы в строке
Ответы на вопрос
Отвечает Козко Софья.
Program znanija;
var s,r:string;
i:integer;
begin
Read(s);
for i:=1 to length(s) do
begin
if s[i] <> ' ' then r:=r+s[i];
end;
Writeln(r);
end.
Один из вариантов решения
var s,r:string;
i:integer;
begin
Read(s);
for i:=1 to length(s) do
begin
if s[i] <> ' ' then r:=r+s[i];
end;
Writeln(r);
end.
Один из вариантов решения
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Pascal для удаления всех пробелов в строке:
```pascal program RemoveSpaces;
var inputString, resultString: string; i: integer;
begin writeln('Введите строку:'); readln(inputString);
resultString := '';
for i := 1 to length(inputString) do begin if inputString[i] <> ' ' then begin resultString := resultString + inputString[i]; end; end;
writeln('Результат:'); writeln(resultString); end. ```
Эта программа запрашивает у пользователя ввод строки, затем проходит по каждому символу в строке и добавляет его в новую строку, если символ не является пробелом. В результате мы получаем строку без пробелов.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
