Вопрос задан 01.08.2018 в 21:23.
Предмет Информатика.
Спрашивает Нн Юлмарт.
Составьте программу сортировки по возрастанию значений трех переменных: A B C. плииииз, умоляю
Ответы на вопрос
Отвечает DELETED.
Var
a, d, c, t: integer;
begin
readln(a, d, c);
if a < d then begin t := a;a := d;d := t; end;
if a < c then begin t := a;a := c;c := t; end;
if d < c then begin t := d;d := c;c := t; end;
writeln(a, ' ', d, ' ', c);
end.
a, d, c, t: integer;
begin
readln(a, d, c);
if a < d then begin t := a;a := d;d := t; end;
if a < c then begin t := a;a := c;c := t; end;
if d < c then begin t := d;d := c;c := t; end;
writeln(a, ' ', d, ' ', c);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа сортировки по возрастанию значений трех переменных A, B, C может выглядеть следующим образом на языке программирования Python:
```python A = int(input("Введите значение переменной A: ")) B = int(input("Введите значение переменной B: ")) C = int(input("Введите значение переменной C: "))
# Сортировка значений переменных if A > B: A, B = B, A if B > C: B, C = C, B if A > B: A, B = B, A
print("Отсортированные значения переменных: ", A, B, C) ```
Эта программа сначала запрашивает у пользователя значения трех переменных A, B, C, затем сортирует их по возрастанию и выводит отсортированные значения.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
