Вопрос задан 06.12.2023 в 23:35. Предмет Информатика. Спрашивает Запоточна Дарья.

Язык Python. Помогите пожалуйста с программированием. Даю 15 баллов. Слон или не слон?Три слепых

мудреца ощупывают предмет и пытаются понять, слон это все-таки или не слон? Всем известно, что у слонов обычно бывают:один хобот;один хвост;4 ноги;2 уха;2 глаза;1 рот.Ну бывают еще бивни, но это как получится, у кого-то уже сломались, у кого-то еще не выросли. Бивни (и другие части тела) считать не будем, они не определяющие.Вам передаются наблюдения мудрецов. Нужно определить, получилось ли им наблюдать хоть одного целого слона? Или, возможно, нескольких? Или не получилось. Если до обеда так ни одного слона и не нашли, пора заканчивать.Формат вводаВводятся пары строк, в первой из которых стоит целое число — количество нащупанных частей тела, во второй — название части тела, количество которой ощупали в предыдущей строке. До тех пор, пока не будет вместо части тела введено слово ОБЕД.Формат выводаЕсли получился хотя бы один полнокомплектный слон, то ввод данных нужно прекратить и вывести: Есть слон! и их количество.Если до появления слова ОБЕД вместо названия так ни одного целого слона и не нашли, вывести: Какие-то слоны нецелые. Пошли обедать.Пример 1Ввод Вывод1нога1рот2хобот3нога2бивень2ухо2глаз1хвост4нога4ОБЕДЕсть слон!1Пример 2Ввод Вывод1глаз1хобот7нога3животик2хвост3нога2бивень5ОБЕДКакие-то слоны нецелые. Пошли обедать.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Муртазин Вадим.

Ответ:

c = 0

hv = 0

hb = 0

nog = 0

yh = 0

rot = 0

gl = 0

kok = ''

g = ''

while g != 'ОБЕД':

   kok = int(input())

   g = input()

   if g == 'хобот':

       hb += kok

   if g == 'хвост':

       hv += kok      

   if 'ног' in g:

       nog += kok        

   if 'ух' in g:

       yh += kok      

   if g == 'рот':

       rot += kok

   if 'гла' in g:

       gl += kok      

   if nog >= 4 and yh >= 2 and gl >= 2 and hb >= 1 and hv >= 1:

       break

s = min((nog // 4), (yh // 2), (gl // 2))

if nog < 4 or yh < 2 or hb < 1 or hv < 1 or rot < 1 or gl < 2:

   print('Какие-то слоны нецелые. Пошли обедать.')

else:

   print('Есть слон!')

   print(s)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

To solve this problem, we need to keep track of the number of body parts felt by the wise men and check if they have observed at least one complete elephant. We can use a dictionary to store the count of each body part. Here's an example solution in Python:

```python body_parts = { 'нога': 0, 'рот': 0, 'хобот': 0, 'ухо': 0, 'глаз': 0, 'хвост': 0, 'бивень': 0 }

while True: count = int(input()) if count == 0: break part = input() body_parts[part] += count

if body_parts['нога'] >= 4 and body_parts['рот'] >= 1 and body_parts['хобот'] >= 1 and body_parts['ухо'] >= 2 and body_parts['глаз'] >= 2 and body_parts['хвост'] >= 1: print("Есть слон!") break

if 'ОБЕД' in part: print("Какие-то слоны нецелые. Пошли обедать.") break ```

Let's go through the code step by step:

1. We initialize a dictionary called `body_parts` to keep track of the count of each body part. 2. We enter a while loop that continues until we encounter the word "ОБЕД" (which means "lunch" in Russian). 3. Inside the loop, we read the count of body parts and the name of the body part from the input. 4. We increment the count of the corresponding body part in the `body_parts` dictionary. 5. We check if we have observed at least one complete elephant by comparing the counts of each body part with the required counts: 4 legs, 1 mouth, 1 trunk, 2 ears, 2 eyes, and 1 tail. If we have observed a complete elephant, we print "Есть слон!" (which means "There is an elephant!" in Russian) and break out of the loop. 6. If we encounter the word "ОБЕД" in the input, we print "Какие-то слоны нецелые. Пошли обедать." (which means "Some elephants are incomplete. Let's go have lunch.") and break out of the loop.

You can run this code and test it with different inputs to see how it works. Let me know if you have any further questions!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос