Даю все свои 35 баллов. Срочно нужно. Программа в паскале Напишите программу, которая в
последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В по сле до ва тель но сти все гда име ет ся число, крат ное 4. Ко ли че ство чисел не пре вы ша ет 1000. Введённые числа не пре вы ша ют 30 000. Про грам ма долж на вы ве сти одно число — ко ли че ство чисел, крат ных 4.Ответы на вопрос
Ответ:
Написал на С++
Объяснение:
#include <iostream>
#include <windows.h>//для русской раскладки
using namespace std;
int main()
{
SetConsoleCP(1251);//подключаем русскую раскладку
SetConsoleOutputCP(1251);
unsigned int kol;//количество чисел в последовательности
unsigned int kratnie4 = 0;//количество чисел кратных 4
do//проверка ввода, что количество чисел не превышает 1000
{
cout << "Введите количество чисел в последовательности (оно должно быть натуральным и меньше 1000): ";
cin >> kol;
} while (kol > 1000);
unsigned int* a = new unsigned int[kol];//инициализируем массив
cout << "Введите элементы массива(они должны быть натуральными и меньше 30000):" << endl;
for (int i = 0; i < kol; i++)
{
do//проверка ввода, что число не превышает 30000
{
cout << "a[" << i + 1 << "] = ";
cin >> a[i];
} while (a[i] > 30000);
}
for (int i = 0; i < kol; i++)
{
if (a[i] % 4 == 0)
kratnie4++;
}
cout << "Количество чисел кратных 4 в последовательности равна: " << kratnie4 << endl;
delete a; // высвобождение памяти
system("pause");
return 0;
}
Я могу помочь вам с написанием программы на языке Pascal. Вот возможный вариант решения вашей задачи:
```pascal program CountMultiplesOfFour; var n, i, x, count: integer; begin writeln('Введите количество чисел в последовательности:'); readln(n); count := 0; writeln('Введите числа:'); for i := 1 to n do begin readln(x); if x mod 4 = 0 then count := count + 1; end; writeln('Количество чисел, кратных 4, равно ', count); end. ```
Эта программа считывает количество чисел в последовательности, а затем считывает сами числа. Для каждого числа она проверяет, делится ли оно на 4 без остатка, и если да, то увеличивает счетчик на 1. В конце она выводит значение счетчика на экран. Это решение соответствует условиям задачи и работает для любых входных данных, удовлетворяющих ограничениям. Я надеюсь, что это поможет вам.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
