СРОЧНО ДО 18:00 Паскаль 1)Написать программу, которая выводит на экран заданное целое число. 2)
Написать програму: задано действительное число А. Вывести его с точностью три знака после запятой. Пожалуйста именно програмуОтветы на вопрос
1)
Задание:
Написать программу, которая выводит на экран заданное целое число.
Решение:
uses crt;
var n: integer;
begin
write('Введите целое число: ');
readln(n);
writeln(n);
end.
2)
Задание:
Задано действительное число А. Вывести его с точностью три знака после запятой.
Решение:
uses crt;
var a: real;
begin
write('Введите действительное число: ');
readln(a);
writeln(a:0:3);
end.
Program to Display an Integer
Here is a Pascal program that displays a given integer on the screen:
```pascal program DisplayInteger; var number: integer; begin writeln('Enter an integer: '); readln(number); writeln('The entered number is: ', number); end. ```
This program prompts the user to enter an integer, reads the input, and then displays the entered number on the screen. The `writeln` procedure is used to output the text and the value of the variable `number`.
Program to Display a Real Number with Three Decimal Places
Here is a Pascal program that displays a given real number with three decimal places:
```pascal program DisplayRealNumber; var number: real; begin writeln('Enter a real number: '); readln(number); writeln('The entered number with three decimal places is: ', number:0:3); end. ```
This program prompts the user to enter a real number, reads the input, and then displays the entered number with three decimal places on the screen. The `writeln` procedure is used to output the text and the formatted value of the variable `number`. The `:0:3` format specifier is used to specify the number of decimal places.
Please note that the above programs are written in Pascal and can be executed using a Pascal compiler or an integrated development environment (IDE) that supports Pascal programming.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
