Вопрос задан 24.11.2023 в 15:08. Предмет Информатика. Спрашивает Кашутин Антон.

Информатика , написать программу в паскаль , задача cash .В багатьох країнах існує традиція

розміщувати портрети своїх політичних лідерів або інших видатних осіб на банкнотах. В таблиці наведені номінали банкнот гривні з зображеними на ньому портретами. Портрет Номінал банкноти Володимир Великий 1 Ярослав Мудрий 2 Богдан Хмельницький 5 Іван Мазепа 10 Іван Франко 20 Михайло Грушевський 50 Тарас Шевченко 100 Леся Українка 200 Григорій Сковорода 500 Напишіть програму, яка буде запитувати в користувача номінал банкноти і відображати на монітор ім’я діяча, портрет якого зображено на відповідному номіналі банкноти. Якщо банкноти введеного номіналу не існує, то повинно виводитися повідомлення про помилку введення.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нужненко Макар.

Ответ на изображении


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

To solve the "cash" problem in Pascal, you can write a program that prompts the user for a banknote denomination and displays the name of the historical figure whose portrait is depicted on the corresponding banknote. If the entered denomination does not exist, the program should display an error message.

Here's an example of how you can write the program in Pascal:

```pascal program Cash; var denomination: integer; begin writeln('Enter the banknote denomination:'); readln(denomination);

case denomination of 1: writeln('Vladimir the Great'); 2: writeln('Yaroslav the Wise'); 5: writeln('Bohdan Khmelnytsky'); 10: writeln('Ivan Mazepa'); 20: writeln('Ivan Franko'); 50: writeln('Mykhailo Hrushevsky'); 100: writeln('Taras Shevchenko'); 200: writeln('Lesya Ukrainka'); 500: writeln('Hryhoriy Skovoroda'); else writeln('Error: Invalid denomination'); end; readln; end. ```

In this program, the user is prompted to enter a banknote denomination. The program then uses a `case` statement to match the entered denomination with the corresponding historical figure's name. If the entered denomination does not match any of the predefined cases, an error message is displayed.

Please note that this program assumes the user will enter a valid integer denomination. If you want to handle invalid input, you can add additional input validation code.

I hope this helps! Let me know if you have any further questions.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос