Вопрос задан 21.11.2023 в 22:33. Предмет Информатика. Спрашивает Федів Антон.

Написать программу на питоне которая будет считывать есть ли в input символы верхнего английского

регистра.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нелинов Амин.

Вот пример программы на Python, которая проверяет, есть ли вводимые символы верхнего английского регистра:

input_str = input("Введите строку: ")

flag_upper = False

for char in input_str:

   if char.isupper():

       flag_upper = True

       break

if flag_upper:

   print("В строке есть символы верхнего английского регистра")

else:

   print("В строке нет символов верхнего английского регистра")

Объяснение:

Программа считывает строку с помощью функции input(), а затем проходит по каждому символу в строке с помощью цикла for. Если хотя бы один символ имеет верхний регистр, то устанавливается флаг flag_upper в значение True. После цикла программа проверяет значение флага и выводит соответствующее сообщение.

0 0
Отвечает Алискеров Рамазан.

Ниже наведен простой скрипт на Python, который проверяет текст на верхний регистр.

string = input('Введите текст для проверки: ')

# Проверка

if any(char.isupper() for char in string if char.isalpha()):

   print('В тексте есть верхний регистр!')

else:

   print('Текст прошёл проверку!\nВ тексте ничего не обнаружено')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи можно использовать методы строки в Python. Вот пример программы, которая будет проверять наличие символов верхнего английского регистра в введенной строке:

```python def check_uppercase_letters(string): # Проходим по каждому символу в строке for char in string: # Проверяем, является ли символ верхним английским символом if char.isupper(): return True # Если найден символ верхнего регистра, возвращаем True return False # Если не найден ни один символ верхнего регистра, возвращаем False

# Считываем входные данные input_string = input("Введите строку: ")

# Проверяем наличие символов верхнего регистра в строке if check_uppercase_letters(input_string): print("В строке есть символы верхнего английского регистра.") else: print("В строке нет символов верхнего английского регистра.") ```

Программа сначала считывает введенную строку с помощью функции `input()`. Затем вызывается функция `check_uppercase_letters()`, которая проходит по каждому символу в строке и проверяет, является ли символ верхним английским символом с помощью метода `isupper()`. Если в строке найден хотя бы один символ верхнего регистра, функция возвращает `True`, и программа выводит сообщение "В строке есть символы верхнего английского регистра". В противном случае функция возвращает `False`, и программа выводит сообщение "В строке нет символов верхнего английского регистра".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос