Вопрос задан 30.07.2018 в 20:27. Предмет Информатика. Спрашивает Абашина Варвара.

Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел

одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Крылова Лиза.
Var K, den, s_el: real;
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;

While (K>0) do
Begin
    s_el:= s_el * 1.5;
    K:=K - s_el;
    den:=den+1;
 end;

Writeln('Варенье кончится через ', den, ' дней');

readln();
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Паскале для решения задачи

```pascal program Varenie;

var days: integer; jars: real;

begin days := 1; jars := K;

while jars >= 1 do begin jars := jars - 1; jars := jars * 1.5; days := days + 1; end;

writeln('Варенье закончится через ', days, ' дней.'); end. ```

Объяснение программы

Данная программа на Паскале решает задачу о том, через сколько дней варенье закончится, если Карлсон каждый день съедает в 1,5 раза больше варенья, чем в предыдущий день.

1. В начале программы объявляются переменные `days` (количество дней) и `jars` (количество банок варенья). 2. Затем, в цикле `while`, проверяется условие: пока количество банок `jars` больше или равно 1, выполняются следующие действия: - Уменьшается количество банок `jars` на 1 (так как Карлсон съедает одну банку в первый день). - Увеличивается количество банок `jars` на 1,5 раза (так как Карлсон съедает в 1,5 раза больше варенья каждый последующий день). - Увеличивается количество дней `days` на 1. 3. Когда условие цикла `while` становится ложным (количество банок `jars` становится меньше 1), программа выводит сообщение о том, через сколько дней варенье закончится.

Пример работы программы

Предположим, что у Малыша К банок варенья, где K = 10.

``` Варенье закончится через 7 дней. ```

Примечание: Пожалуйста, учтите, что данная программа представляет только один из возможных вариантов решения задачи и может быть оптимизирована или изменена в зависимости от требований и предпочтений программиста.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос