Вопрос задан 30.07.2018 в 18:42. Предмет Информатика. Спрашивает Bezrodnaya Alina.

В С++ Составить программу нахождения числа строк матрицы А(6,6), максимальный элемент которых

больше Р
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Исхаков Илья.
#include <iostream>
using namespace std;

int main() {
  const int S = 6;
  int matrix[S][S];
  cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
  for (int i = 0; i < S; i++) {
    for (int j = 0; j < S; j++) {
      cin >> matrix[i][j];
    }
    cout << endl;
  }
  int p;
  cout << "p = ";
  cin >> p;
  int count = 0, max;
  for (int i = 0; i < S; i++) {
    max = matrix[i][0];
    for (int j = 1; j < S; j++) {
      if (matrix[i][j] > max) max = matrix[i][j];
    }
    if (max > p) count++;
  }
  cout << endl << "Ответ: " << count;
  return 0;
}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи, вам потребуется написать программу на языке программирования C++. Вот пример программы, которая находит количество строк матрицы А(6,6), максимальный элемент которых больше числа Р:

```cpp #include using namespace std;

int main() { int A[6][6]; // объявление матрицы размером 6x6 int P; // число Р

// Ввод элементов матрицы А cout << "Введите элементы матрицы А(6,6):" << endl; for (int i = 0; i < 6; i++) { for (int j = 0; j < 6; j++) { cin >> A[i][j]; } }

// Ввод числа Р cout << "Введите число Р:" << endl; cin >> P;

int count = 0; // счетчик строк с максимальным элементом больше Р

// Поиск строк с максимальным элементом больше Р for (int i = 0; i < 6; i++) { int maxElement = A[i][0]; // предполагаем, что первый элемент строки - максимальный for (int j = 1; j < 6; j++) { if (A[i][j] > maxElement) { maxElement = A[i][j]; } } if (maxElement > P) { count++; } }

// Вывод результата cout << "Количество строк матрицы А, максимальный элемент которых больше числа Р: " << count << endl;

return 0; } ```

Программа запрашивает у пользователя ввод элементов матрицы А(6,6) и числа Р. Затем она проходит по каждой строке матрицы, находит максимальный элемент и сравнивает его с числом Р. Если максимальный элемент больше Р, то увеличивает счетчик count. В конце программа выводит количество строк матрицы А, максимальный элемент которых больше числа Р.

Примечание: Представленный код является примером и может потребовать доработки в зависимости от требований и особенностей вашей среды разработки.

Источник 'Algorithms-and-Data-Structures-in-Python/README.md at main ...'

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос