
Напишите программу Мобильный телефон Василия поддерживает только транслит поэтому он передаёт вида
N Bochek Например 3 bochki или 1 bochka.напишите программу которая выбирает правильное слово из bochka bochki bochek в зависимости от N (Паскаль)

Ответы на вопрос

var
n:integer;
md:real;
s1, s2, s3:set of real;
begin
s1:=[1.0]; s2:=[2.0, 3.0, 4.0]; s3:=[0.0, 5.0, 6.0, 7.0, 8.0, 9.0];
n:=ReadInteger('Введите n: ');
md:=n mod 10;
if (md in s1) and (n < 10) then
write('bochka')
else if md in s2 then
write('bochki')
else
write(n, ' bochek');
end.




В Паскале просто реализовать программу для выбора правильного слова в зависимости от числа N. Вот пример простой программы:
```pascal program TranslitChooser;
var N: Integer;
begin writeln('Введите число N:'); readln(N);
case N of 1: writeln('bochka'); 2, 3, 4: writeln('bochki'); else writeln('bochek'); end;
readln; end. ```
Объяснение:
1. Программа начинается с объявления переменной `N`, которая представляет число, введенное пользователем. 2. Пользователю предлагается ввести число N. 3. Затем используется конструкция `case`, чтобы выбрать правильное слово в зависимости от значения N. - Если N равно 1, программа выводит 'bochka'. - Если N равно 2, 3 или 4, программа выводит 'bochki'. - Во всех остальных случаях (N не равно 1, 2, 3 или 4), программа выводит 'bochek'. 4. `readln` используется для ожидания ввода пользователя перед завершением программы.
Просто скопируйте этот код в среду программирования Pascal и выполните его. После ввода числа N программа выдаст соответствующее слово.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili