Вопрос задан 15.11.2023 в 11:21. Предмет Информатика. Спрашивает Джумоляк Анастасия.

Питон Хогвартс устроил рассылку писем. На каждом письме есть шестизначный почтовый индекс, а так

же каждое письмо доставляется с совой особого цвета. С клавиатуры вводится N - количество писем, отправленных сегодня. Затем на отдельных строках вводится N пар: индекс и цвет совы, где индекс - это шестизначное целое число, цвет совы обозначается словом. Если последние две цифры индекса - это 01, то письмо отправлено в Лондон. Посчитатйте количество писем, отправленных в Лондон сегодня с белой совой. Формат входных данных 0 ≤ N ≤ 1000 - количество писем Затем на отдельных строках вводится N пар: индекс и цвет совы, где индекс - это шестизначное целое число, цвет совы обозначается словом. Формат выходных данных Одно число - ответ.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Безкишкина Диана.

Решение:

n=int(input()) #ввод кол-ва писем

c=0 #счётчик

for i in range(n): #делаем ввод n раз

   ind=int(input()) #ввод индекса

   s=input() #ввод цвета совы

   if str(ind)[-2:]=='01' and s=='белый': #проверка

       c+=1 #прибавляем счётчик

print(c) #вывод

       

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я попробую написать код на Python, который решает эту задачу. Вот мой код:

```python # Вводим количество писем N = int(input("Введите количество писем: "))

# Создаем переменную для подсчета писем в Лондон с белой совой count = 0

# Повторяем N раз for i in range(N): # Вводим индекс и цвет совы index, color = input("Введите индекс и цвет совы: ").split() # Преобразуем индекс в целое число index = int(index) # Проверяем, что последние две цифры индекса равны 01 и цвет совы белый if index % 100 == 1 and color == "белый": # Увеличиваем счетчик на 1 count += 1

# Выводим результат print("Количество писем, отправленных в Лондон с белой совой:", count) ```

Надеюсь, это поможет вам.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос