Вопрос задан 13.11.2023 в 20:40. Предмет Информатика. Спрашивает Agabaev Zhandos.

Питон написать программу Поле шахматной доски определяется парой натуральных чисел, каждое из

которых не превосходит восьми: первое число—номер вертикали (при счете слева направо - столбец), второе—номер горизонтали (при счете снизу вверх - строка). Даны натуральные числа k, l, каждое из которых не превосходит восьми (каждое число вводится на отдельной строке). Выяснить какого цвета поле (k, l), если поле А1 - черного цвета. Ответ: белое/черное
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Старостина Алена.

Відповідь:

i1= int(input())

i2= int(input())

if (i1+i2)%2==0:

   print("черное")

else:

   print("белое")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Python для определения цвета поля на шахматной доске, заданного парой целых чисел (k, l), может выглядеть следующим образом:

```python def determine_color(k, l): if (k + l) % 2 == 0: return "белое" else: return "черное"

# Ввод координат поля k = int(input("Введите номер вертикали (1-8): ")) l = int(input("Введите номер горизонтали (1-8): "))

color = determine_color(k, l) print(f"Цвет поля ({k}, {l}) - {color}") ```

В этой программе мы определяем функцию `determine_color`, которая принимает два аргумента, `k` и `l`, представляющие номер вертикали и горизонтали соответственно. Внутри функции, мы используем операцию `%` для проверки остатка от деления суммы `k + l` на 2. Если остаток равен 0, то поле будет белым, иначе - черным.

Затем мы запрашиваем у пользователя ввод значений `k` и `l`, используя функцию `input` и преобразуя результат в целые числа с помощью `int()`. После этого мы вызываем функцию `determine_color` с введенными значениями `k` и `l` и сохраняем результат в переменную `color`. Наконец, мы выводим сообщение о цвете поля, используя ф-строку для форматирования.

Пожалуйста, обратите внимание, что в данной программе предполагается, что пользователь вводит значения `k` и `l` в диапазоне от 1 до 8, соответствующие номерам вертикали и горизонтали шахматной доски.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос