PASCAL!! Составить программу, которая по введенной начальной букве выводит название цветов радуги
(красный, оранжевый, желтый, зеленый, голубой, синий, фиолетовый).Ответы на вопрос
var a:char;
begin
readln(a) ;
if a = 'к' then
writeln('красный') ;
if a = 'о' then
writeln('оранжевый') ;
if a = 'ж' then
writeln('желтый') ;
if a = 'з' then
writeln('зеленый') ;
if a = 'г' then
writeln('голубой') ;
if a = 'с' then
writeln('синий') ;
if a = 'ф' then
writeln('фиолетовый') ;
end.
Конечно, вот пример программы на языке Pascal, которая выводит название цветов радуги, соответствующих введенной начальной букве:
```pascal program RainbowColors;
uses crt;
var initialLetter: char;
begin writeln('Введите начальную букву цвета радуги: '); readln(initialLetter);
case upcase(initialLetter) of 'К': writeln('Красный'); 'О': writeln('Оранжевый'); 'Ж': writeln('Желтый'); 'З': writeln('Зеленый'); 'Г': writeln('Голубой'); 'С': writeln('Синий'); 'Ф': writeln('Фиолетовый'); else writeln('Нет цвета радуги, начинающегося с этой буквы.'); end;
readkey; end. ```
Эта программа запрашивает у пользователя начальную букву цвета радуги. Затем, используя оператор `case`, определяет, какой цвет соответствует введенной букве. Если введенная буква не соответствует ни одному из цветов радуги, программа сообщит об этом.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
