
Срочно нужно!!!Помогите!!!1.Составить программу, которая спрашивает возраст человека и, если ему 18
лет и больше, сообщает “Замечательно. Вы уже можете водить автомобиль”, а в противном случае – “К сожалению, водить автомобиль Вам рановато”.2. Определить номер подъезда девятиэтажного дома по указанному номеру квартиры N. Считать, что на каждом этаже находится M квартир.3. Написать программу, которая бы запрашивала целое число и выводила любое его значение, кроме 13. Если заданное число равно 13, вместо него печатается число 77.по примеру :program www;var x,y: integer;begin writeln ('...'); readln (x,y);if ...( условие) then writeln (значит-то то) else writeln (иначе-то то)

Ответы на вопрос

var a:integer;
begin
writeln ('Сколько вам лет?');
read (a);
if (a>=18) then writeln ('Замечательно. Вы уже можете водить автомобиль') else writeln ('К сожалению, водить автомобиль Вам рановато');
end.



1. Программа, которая спрашивает возраст человека и сообщает, может ли он водить автомобиль:
program CanDriveCar; var age: integer; begin writeln('Введите ваш возраст:'); readln(age); if age >= 18 then writeln('Замечательно. Вы уже можете водить автомобиль') else writeln('К сожалению, водить автомобиль Вам рановато'); end.
2. Программа для определения номера подъезда девятиэтажного дома по указанному номеру квартиры:
program FindEntrance; var apartmentNumber, entranceNumber, totalApartments, apartmentsPerFloor: integer; begin writeln('Введите номер квартиры:'); readln(apartmentNumber); writeln('Введите общее количество квартир в доме:'); readln(totalApartments); writeln('Введите количество квартир на одном этаже:'); readln(apartmentsPerFloor); entranceNumber := (apartmentNumber - 1) div (totalApartments div 9) + 1; writeln('Номер подъезда: ', entranceNumber); end.
3. Программа, которая запрашивает целое число и выводит любое его значение, кроме 13, заменяя его на 77:
program ReplaceNumber; var number: integer; begin writeln('Введите целое число:'); readln(number); if number = 13 then writeln('77') else writeln(number); end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili